ubuntu 编译Qt4.8.6出现Basic XLib functionality test failed!


在./configure时候,出现Basic XLib functionality test failed!这个问题,这个问题似乎好多人都有遇见过,这里附上解决方法:


查找原因:

此完整出错信息是在./configure阶段

Basic XLib functionality test failed! You might need to modify the include and library search paths by editing QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in /home/zhu/Qt/qt-x11-opensource-src-4.5.2/mkspecs/linux-g++


进config.test / x11/xlib 执行make命令,看出错信息:

g++ -Wl,-O1 -o xlib xlib.o    -L/usr/X11R6/lib -lXext -lX11 -lm /usr/bin/ld: cannot find -lXext


看到了吧,g++在/usr/X11R6/lib下,找不到libXext.so呢。其原因就在于需要安装libX11的开发包,在ubuntu/debian里包名都是libX11-dev,根据以往的经验,在./configure前主动装好下面3个包,基本上就万事大吉了


解决方法:

sudo apt-get install libX11-dev libXext-dev libXtst-dev


答案来自网络,感谢广大网友


上一篇 下一篇